CVE-2017-18214

NameCVE-2017-18214
DescriptionThe moment module before 2.19.3 for Node.js is prone to a regular expression denial of service via a crafted date string, a different vulnerability than CVE-2016-4055.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-moment (PTS)stretch2.17.1+ds-1vulnerable
buster, sid2.22.2+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-momentsource(unstable)2.19.3+ds-1unimportant

Notes

fixed in 2.19.3 upstream
https://github.com/moment/moment/commit/69ed9d44957fa6ab12b73d2ae29d286a857b80eb
https://github.com/moment/moment/pull/4326
https://github.com/moment/moment/issues/4163
https://nodesecurity.io/advisories/532
nodejs not covered by security support

Search for package or bug name: Reporting problems