CVE-2017-18232

NameCVE-2017-18232
DescriptionThe Serial Attached SCSI (SAS) implementation in the Linux kernel through 4.15.9 mishandles a mutex within libsas, which allows local users to cause a denial of service (deadlock) by triggering certain error-handling code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4187-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1fixed
jessie (security)3.16.68-2fixed
stretch4.9.168-1vulnerable
stretch (security)4.9.168-1+deb9u4vulnerable
bullseye, buster4.19.37-5fixed
buster (security)4.19.37-5+deb10u1fixed
sid4.19.37-6fixed
linux-4.9 (PTS)jessie (security)4.9.168-1+deb9u3~deb8u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.15.17-1low
linuxsourcejessie3.16.56-1lowDSA-4187-1
linuxsourcewheezy(not affected)
linux-4.9sourcejessie(unfixed)low

Notes

[stretch] - linux <ignored> (Minor issue)
[jessie] - linux <ignored> (Minor issue)
[wheezy] - linux <not-affected> (Vulnerability introduced later)
Fixed by: https://git.kernel.org/linus/0558f33c06bb910e2879e355192227a8e8f0219d

Search for package or bug name: Reporting problems