CVE-2017-18237

NameCVE-2017-18237
DescriptionAn issue was discovered in Exempi before 2.4.3. The PostScript_Support::ConvertToDate function in XMPFiles/source/FormatSupport/PostScript_Support.cpp allows remote attackers to cause a denial of service (invalid pointer dereference and application crash) via a crafted .ps file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exempi (PTS)jessie2.2.1-2vulnerable
stretch2.4.1-1vulnerable
buster2.5.0-2fixed
bullseye, sid2.5.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exempisource(unstable)2.4.3-1low
exempisourcewheezy(not affected)

Notes

[stretch] - exempi <no-dsa> (Minor issue)
[jessie] - exempi <no-dsa> (Minor issue)
[wheezy] - exempi <not-affected> (vulnerable code not present)
https://bugs.freedesktop.org/show_bug.cgi?id=101914
https://cgit.freedesktop.org/exempi/commit/?id=f19d0107fbae1fb41836cd110d4425e407e64048

Search for package or bug name: Reporting problems