CVE-2017-18258

NameCVE-2017-18258
DescriptionThe xz_head function in xzlib.c in libxml2 before 2.9.6 allows remote attackers to cause a denial of service (memory consumption) via a crafted LZMA file, because the decoder functionality does not restrict memory usage to what is required for a legitimate file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1524-1
NVD severitymedium (attack range: remote)
Debian Bugs895245

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)jessie2.9.1+dfsg1-5+deb8u6vulnerable
jessie (security)2.9.1+dfsg1-5+deb8u7fixed
stretch (security), stretch2.9.4+dfsg1-2.2+deb9u2vulnerable
buster, sid2.9.4+dfsg1-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)(unfixed)medium895245
libxml2sourcejessie2.9.1+dfsg1-5+deb8u7mediumDLA-1524-1

Notes

[stretch] - libxml2 <postponed> (Minor issue; wait for upstream fix for upstream bug 794914)
[wheezy] - libxml2 <postponed> (Minor issue; wait for upstream fix for upstream bug 794914)
https://bugzilla.gnome.org/show_bug.cgi?id=786696
Fixed by: https://git.gnome.org/browse/libxml2/commit/?id=e2a9122b8dde53d320750451e9907a7dcb2ca8bb
When fixing this issue make sure to not open CVE-2018-9251 and apply
the fix for CVE-2018-9251 / https://bugzilla.gnome.org/show_bug.cgi?id=794914

Search for package or bug name: Reporting problems