CVE-2017-18342

NameCVE-2017-18342
DescriptionIn PyYAML before 5.1, the yaml.load() API could execute arbitrary code if used with untrusted data. The load() function has been deprecated in version 5.1 and the 'UnsafeLoader' has been introduced for backward compatibility with the function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs902878

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pyyaml (PTS)stretch3.12-1vulnerable
buster3.13-2vulnerable
bullseye5.3.1-5fixed
bookworm, sid5.4.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pyyamlsource(unstable)5.1.2-1unimportant902878

Notes

This is a well-known design deficiency in pyyaml, various CVE IDs have been assigned
to applications misusing the API over the years. The CVE ID was assigned to raise
awareness (and 5.1 now fixes the default behaviour as well)
https://github.com/yaml/pyyaml/pull/74

Search for package or bug name: Reporting problems