CVE-2017-2579

NameCVE-2017-2579
DescriptionAn out-of-bounds read vulnerability was found in netpbm before 10.61. The expandCodeOntoStack() function has an insufficient code value check, so that a maliciously crafted file could cause the application to crash or possibly allows code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs854978

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netpbm-free (PTS)jessie2:10.0-15.2undetermined
buster, stretch, sid2:10.0-15.3undetermined

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
netpbm-freesource(unstable)undetermined854978

Notes

Debian uses an old fork of netpbm
http://www.openwall.com/lists/oss-security/2017/02/05/7

Search for package or bug name: Reporting problems