CVE-2017-2580

NameCVE-2017-2580
DescriptionAn out-of-bounds write vulnerability was found in netpbm before 10.61. A maliciously crafted file could cause the application to crash or possibly allow code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs854978

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netpbm-free (PTS)jessie2:10.0-15.2undetermined
buster, sid, stretch2:10.0-15.3undetermined

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
netpbm-freesource(unstable)undeterminedmedium854978

Notes

Debian uses an old fork of netpbm
http://www.openwall.com/lists/oss-security/2017/02/05/7

Search for package or bug name: Reporting problems