CVE-2017-2581

NameCVE-2017-2581
DescriptionAn out-of-bounds write vulnerability was found in netpbm before 10.61. A maliciously crafted file could cause the application to crash or possibly allow code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs854978

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netpbm-free (PTS)buster, stretch2:10.0-15.3fixed
bullseye2:10.0-15.4fixed
bookworm, sid2:10.97.00-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
netpbm-freesourcestretch(not affected)
netpbm-freesourcebuster(not affected)
netpbm-freesourcebullseye(not affected)
netpbm-freesource(unstable)2:10.97.00-1854978

Notes

[bullseye] - netpbm-free <not-affected> (Legacy fork not affected)
[buster] - netpbm-free <not-affected> (Legacy fork not affected)
[stretch] - netpbm-free <not-affected> (Legacy fork not affected)
Debian uses an old fork of netpbm, switched to current releases as of 2:10.97.00-1
https://www.openwall.com/lists/oss-security/2017/02/05/7
PoC+report attached to #854978
Similar code path seems protected by earlier stricter size checks ("object too large")
Possible fix: https://sourceforge.net/p/netpbm/code/2989/ (10.78.05)

Search for package or bug name: Reporting problems