CVE-2017-2619

NameCVE-2017-2619
DescriptionSamba before versions 4.6.1, 4.5.7 and 4.4.11 are vulnerable to a malicious client using a symlink race to allow access to areas of the server file system not exported under the share definition.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-894-1, DSA-3816-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)jessie (security), jessie2:4.2.14+dfsg-0+deb8u9fixed
stretch (security), stretch2:4.5.12+dfsg-2+deb9u2fixed
buster, sid2:4.8.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.5.6+dfsg-2medium
sambasourcejessie2:4.2.14+dfsg-0+deb8u4mediumDSA-3816-1
sambasourcewheezy2:3.6.6-6+deb7u12mediumDLA-894-1

Notes

https://www.samba.org/samba/security/CVE-2017-2619.html

Search for package or bug name: Reporting problems