CVE-2017-2640

NameCVE-2017-2640
DescriptionAn out-of-bounds write flaw was found in the way Pidgin before 2.12.0 processed XML content. A malicious remote server could potentially use this flaw to crash Pidgin or execute arbitrary code in the context of the pidgin process.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-853-1, DSA-3806-1
Debian Bugs859159

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pidgin (PTS)jessie, jessie (security)2.11.0-0+deb8u2fixed
stretch2.12.0-1fixed
buster, sid2.13.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pidginsource(unstable)2.12.0-1859159
pidginsourcejessie2.11.0-0+deb8u2DSA-3806-1
pidginsourcewheezy2.10.10-1~deb7u3DLA-853-1

Notes

https://www.pidgin.im/news/security/?id=109
https://bitbucket.org/pidgin/main/commits/b2fc9e774cb9

Search for package or bug name: Reporting problems