CVE-2017-2659

NameCVE-2017-2659
DescriptionIt was found that dropbear before version 2013.59 with GSSAPI leaks whether given username is valid or invalid. When an invalid username is given, the GSSAPI authentication failure was incorrectly counted towards the maximum allowed number of password attempts.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dropbear (PTS)stretch2016.74-5+deb9u1fixed
buster2018.76-5fixed
bullseye2020.81-3fixed
bookworm, sid2022.82-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dropbearsource(unstable)2013.60-1

Notes

https://hg.ucc.asn.au/dropbear/rev/d7784616409a#l1.86

Search for package or bug name: Reporting problems