CVE-2017-2669

NameCVE-2017-2669
DescriptionDovecot before version 2.2.29 is vulnerable to a denial of service. When 'dict' passdb and userdb were used for user authentication, the username sent by the IMAP/POP3 client was sent through var_expand() to perform %variable expansion. Sending specially crafted %variable fields could result in excessive memory usage causing the process to crash (and restart), or excessive CPU usage causing all authentications to hang.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs860049

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dovecot (PTS)jessie (security), jessie1:2.2.13-12~deb8u4fixed
stretch (security), stretch1:2.2.27-3+deb9u2fixed
buster, sid1:2.3.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dovecotsource(unstable)1:2.2.27-3860049
dovecotsourcejessie(not affected)
dovecotsourcewheezy(not affected)

Notes

[jessie] - dovecot <not-affected> (Vulnerable code not present)
[wheezy] - dovecot <not-affected> (Vulnerable code not present)
Fixed by: https://github.com/dovecot/core/commit/000030feb7a30f193197f1aab8a7b04a26b42735
Introduced by: https://github.com/dovecot/core/commit/a3783f8a3c9cd816b51e77a922f82301512fcf22

Search for package or bug name: Reporting problems