DescriptionAn exploitable integer overflow vulnerability exists in the JPEG 2000 image parsing functionality of Poppler 0.53.0. A specially crafted PDF file can lead to an integer overflow causing out of bounds memory overwrite on the heap resulting in potential arbitrary code execution. To trigger this vulnerability, a victim must open the malicious PDF in an application using this library.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)wheezy0.18.4-6vulnerable
wheezy (security)0.18.4-6+deb7u5vulnerable
jessie (security)0.26.5-2+deb8u3vulnerable
stretch (security), stretch0.48.0-2+deb9u2vulnerable
buster, sid0.62.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


Debian uses openjpeg for processing JPEG 2000 images, this advisory is
against Ubuntu, which disables openjpeg due to being in universe

Search for package or bug name: Reporting problems