CVE-2017-2838

NameCVE-2017-2838
DescriptionRdp Client License Read Product Info Denial of Service
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1095-1, DSA-3923-1
Debian Bugs869880

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freerdp (PTS)wheezy1.0.1-1.1+deb7u3vulnerable
wheezy (security)1.0.1-1.1+deb7u4fixed
jessie1.1.0~git20140921.1.440916e+dfsg1-4vulnerable
jessie (security)1.1.0~git20140921.1.440916e+dfsg1-4+deb8u1fixed
stretch1.1.0~git20140921.1.440916e+dfsg1-13+deb9u2fixed
stretch (security)1.1.0~git20140921.1.440916e+dfsg1-13+deb9u1fixed
buster, sid1.1.0~git20140921.1.440916e+dfsg1-15fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freerdpsource(unstable)1.1.0~git20140921.1.440916e+dfsg1-14869880
freerdpsourcejessie1.1.0~git20140921.1.440916e+dfsg1-4+deb8u1DSA-3923-1
freerdpsourcestretch1.1.0~git20140921.1.440916e+dfsg1-13+deb9u1DSA-3923-1
freerdpsourcewheezy1.0.1-1.1+deb7u4DLA-1095-1

Notes

https://www.talosintelligence.com/vulnerability_reports/TALOS-2017-0340
http://blog.talosintelligence.com/2017/07/vulnerbility-spotlight-freerdp-multiple.html
https://github.com/FreeRDP/FreeRDP/commit/03ab68318966c3a22935a02838daaea7b7fbe96c (1.1)

Search for package or bug name: Reporting problems