CVE-2017-2870

NameCVE-2017-2870
DescriptionAn exploitable integer overflow vulnerability exists in the tiff_image_parse functionality of Gdk-Pixbuf 2.36.6 when compiled with Clang. A specially crafted tiff file can cause a heap-overflow resulting in remote code execution. An attacker can send a file or a URL to trigger this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs873787

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gdk-pixbuf (PTS)wheezy2.26.1-1+deb7u3vulnerable
wheezy (security)2.26.1-1+deb7u6vulnerable
jessie2.31.1-2+deb8u5vulnerable
jessie (security)2.31.1-2+deb8u6vulnerable
stretch (security), stretch2.36.5-2+deb9u1vulnerable
buster, sid2.36.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gdk-pixbufsource(unstable)2.36.10-1unimportant873787

Notes

https://git.gnome.org/browse/gdk-pixbuf/commit/?id=31a6cff3dfc6944aad4612a9668b8ad39122e48b
https://bugzilla.gnome.org/show_bug.cgi?id=770986
https://bugzilla.gnome.org/show_bug.cgi?id=780269
Built with GCC in Debian, which doesn't remove the check

Search for package or bug name: Reporting problems