CVE-2017-2885

NameCVE-2017-2885
Descriptionstack based buffer overflow with HTTP Chunked Encoding
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3929-1
Debian Bugs871650

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsoup2.4 (PTS)wheezy2.38.1-3fixed
jessie2.48.0-1vulnerable
jessie (security)2.48.0-1+deb8u1fixed
stretch (security), stretch2.56.0-2+deb9u1fixed
buster, sid2.60.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsoup2.4source(unstable)2.56.1-1871650
libsoup2.4sourcejessie2.48.0-1+deb8u1DSA-3929-1
libsoup2.4sourcestretch2.56.0-2+deb9u1DSA-3929-1
libsoup2.4sourcewheezy(not affected)

Notes

[wheezy] - libsoup2.4 <not-affected> (Vulnerable code not present)
https://bugzilla.gnome.org/show_bug.cgi?id=785774

Search for package or bug name: Reporting problems