CVE-2017-2902

NameCVE-2017-2902
DescriptionAn exploitable integer overflow exists in the DPX loading functionality of the Blender open-source 3d creation suite version 2.78c. A specially crafted '.cin' file can cause an integer overflow resulting in a buffer overflow which can allow for code execution under the context of the application. An attacker can convince a user to use the file as an asset via the sequencer in order to trigger this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
blender (PTS)jessie2.72.b+dfsg0-3vulnerable
stretch2.78.a+dfsg0-4vulnerable
buster2.79.b+dfsg0-1fixed
sid2.79.b+dfsg0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
blendersource(unstable)2.79.a+dfsg0-1medium

Notes

[wheezy] - blender <ignored> (Vulnerable but not ignored)
https://git.blender.org/gitweb/gitweb.cgi/blender.git/commit/d30cc1ea0b9ba64d8a1e22105528b6cb8077692c
https://www.talosintelligence.com/vulnerability_reports/TALOS-2017-0409

Search for package or bug name: Reporting problems