CVE-2017-3523

NameCVE-2017-3523
DescriptionVulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/J). Supported versions that are affected are 5.1.40 and earlier. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. While the vulnerability is in MySQL Connectors, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of MySQL Connectors. CVSS 3.0 Base Score 8.5 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-945-1, DSA-3840-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mysql-connector-java (PTS)wheezy5.1.16-2vulnerable
wheezy (security)5.1.42-1~deb7u1fixed
jessie (security), jessie5.1.42-1~deb8u1fixed
stretch5.1.42-1fixed
buster, sid5.1.44-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mysql-connector-javasource(unstable)5.1.41-1medium
mysql-connector-javasourcejessie5.1.41-1~deb8u1mediumDSA-3840-1
mysql-connector-javasourcewheezy5.1.42-1~deb7u1mediumDLA-945-1

Notes

https://www.computest.nl/advisories/CT-2017-0425_MySQL-Connector-J.txt

Search for package or bug name: Reporting problems