CVE-2017-3586

NameCVE-2017-3586
DescriptionVulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/J). Supported versions that are affected are 5.1.41 and earlier. Easily "exploitable" vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. While the vulnerability is in MySQL Connectors, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Connectors accessible data as well as unauthorized read access to a subset of MySQL Connectors accessible data. CVSS 3.0 Base Score 6.4 (Confidentiality and Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-945-1, DSA-3857-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mysql-connector-java (PTS)wheezy5.1.16-2vulnerable
wheezy (security)5.1.42-1~deb7u1fixed
jessie (security), jessie5.1.42-1~deb8u1fixed
buster, sid, stretch5.1.42-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mysql-connector-javasource(unstable)5.1.42-1medium
mysql-connector-javasourcejessie5.1.42-1~deb8u1mediumDSA-3857-1
mysql-connector-javasourcewheezy5.1.42-1~deb7u1mediumDLA-945-1

Search for package or bug name: Reporting problems