CVE-2017-3589

NameCVE-2017-3589
DescriptionVulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/J). Supported versions that are affected are 5.1.41 and earlier. Easily "exploitable" vulnerability allows low privileged attacker with logon to the infrastructure where MySQL Connectors executes to compromise MySQL Connectors. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Connectors accessible data. CVSS 3.0 Base Score 3.3 (Integrity impacts). CVSS Vector: (CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-945-1, DSA-3857-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mysql-connector-java (PTS)wheezy5.1.16-2vulnerable
wheezy (security)5.1.42-1~deb7u1fixed
jessie5.1.39-1~deb8u1vulnerable
jessie (security)5.1.42-1~deb8u1fixed
buster, stretch, sid5.1.42-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mysql-connector-javasource(unstable)5.1.42-1low
mysql-connector-javasourcejessie5.1.42-1~deb8u1lowDSA-3857-1
mysql-connector-javasourcewheezy5.1.42-1~deb7u1lowDLA-945-1

Search for package or bug name: Reporting problems