CVE-2017-3730

NameCVE-2017-3730
DescriptionIn OpenSSL 1.1.0 before 1.1.0d, if a malicious server supplies bad parameters for a DHE or ECDHE key exchange then this can result in the client attempting to dereference a NULL pointer leading to a client crash. This could be exploited in a Denial of Service attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)wheezy1.0.1e-2+deb7u20fixed
wheezy (security)1.0.1t-1+deb7u2fixed
jessie (security), jessie1.0.1t-1+deb8u6fixed
stretch1.1.0f-3fixed
buster, sid1.1.0f-5fixed
openssl1.0 (PTS)buster, sid, stretch1.0.2l-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)1.1.0d-1medium
opensslsourcejessie(not affected)
opensslsourcewheezy(not affected)
openssl1.0source(unstable)(not affected)

Notes

[jessie] - openssl <not-affected> (Only affects OpenSSL 1.1)
[wheezy] - openssl <not-affected> (Only affects OpenSSL 1.1)
- openssl1.0 <not-affected> (Only affects OpenSSL 1.1)
https://www.openssl.org/news/secadv/20170126.txt

Search for package or bug name: Reporting problems