CVE-2017-3733

NameCVE-2017-3733
DescriptionDuring a renegotiation handshake if the Encrypt-Then-Mac extension is negotiated where it was not in the original handshake (or vice-versa) then this can cause OpenSSL 1.1.0 before 1.1.0e to crash (dependent on ciphersuite). Both clients and servers are affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)buster1.1.1n-0+deb10u3fixed
buster (security)1.1.1n-0+deb10u6fixed
bullseye1.1.1w-0+deb11u1fixed
bullseye (security)1.1.1n-0+deb11u5fixed
bookworm, bookworm (security)3.0.11-1~deb12u2fixed
trixie3.2.1-3fixed
sid3.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsourcewheezy(not affected)
opensslsourcejessie(not affected)
opensslsource(unstable)1.1.0e-1
openssl1.0source(unstable)(not affected)

Notes

[jessie] - openssl <not-affected> (Only affects 1.1)
[wheezy] - openssl <not-affected> (Only affects 1.1)
- openssl1.0 <not-affected> (Only affects 1.1)
https://www.openssl.org/news/secadv/20170216.txt

Search for package or bug name: Reporting problems