CVE-2017-5208

NameCVE-2017-5208
DescriptionInteger overflow in the wrestool program in icoutils before 0.31.1 allows remote attackers to cause a denial of service (memory corruption) via a crafted executable, which triggers a denial of service (application crash) or the possibility of execution of arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-789-1, DSA-3756-1
NVD severitymedium (attack range: remote)
Debian Bugs850017

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icoutils (PTS)wheezy0.29.1-5vulnerable
wheezy (security)0.29.1-5deb7u2fixed
jessie (security), jessie0.31.0-2+deb8u3fixed
stretch0.31.2-1.1fixed
buster, sid0.32.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icoutilssource(unstable)0.31.0-4medium850017
icoutilssourcejessie0.31.0-2+deb8u1mediumDSA-3756-1
icoutilssourcewheezy0.29.1-5deb7u1mediumDLA-789-1

Notes

Fixed by: http://git.savannah.gnu.org/cgit/icoutils.git/commit/?id=0d569f458f306b88f60156d60c9cf058125cf173
http://www.openwall.com/lists/oss-security/2017/01/08/1

Search for package or bug name: Reporting problems