CVE-2017-5225

NameCVE-2017-5225
DescriptionLibTIFF version 4.0.7 is vulnerable to a heap buffer overflow in the tools/tiffcp resulting in DoS or code execution via a crafted BitsPerSample value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-795-1, DSA-3844-1
NVD severityhigh (attack range: remote)
Debian Bugs851297

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)wheezy4.0.2-6+deb7u5vulnerable
wheezy (security)4.0.2-6+deb7u17fixed
jessie (security), jessie4.0.3-12.3+deb8u4fixed
stretch (security), stretch4.0.8-2+deb9u1fixed
buster, sid4.0.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)4.0.7-5high851297
tiffsourcejessie4.0.3-12.3+deb8u3highDSA-3844-1
tiffsourcewheezy4.0.2-6+deb7u9highDLA-795-1

Notes

Fixed by: https://github.com/vadz/libtiff/commit/5c080298d59efa53264d7248bbe3a04660db6ef7
http://bugzilla.maptools.org/show_bug.cgi?id=2656
http://bugzilla.maptools.org/show_bug.cgi?id=2657

Search for package or bug name: Reporting problems