CVE-2017-5330

NameCVE-2017-5330
Descriptionark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an archive, related to associated applications.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs850874

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ark (PTS)stretch4:16.08.3-2fixed
buster4:18.08.3-1fixed
buster (security)4:18.08.3-1+deb10u1fixed
bullseye, sid4:20.04.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
arksourcewheezy(not affected)
arksourcejessie(not affected)
arksource(unstable)4:16.08.3-2850874

Notes

[jessie] - ark <not-affected> (Vulnerable code introduced later)
[wheezy] - ark <not-affected> (Vulnerable code introduced later)
Fixed by: https://cgit.kde.org/ark.git/commit/?id=82fdfd24d46966a117fa625b68784735a40f9065
"Open File" action introduced in https://cgit.kde.org/ark.git/commit/?id=f1cf10f25af245823f81b8ff457a04c7593dede7 (v15.11.80)

Search for package or bug name: Reporting problems