CVE-2017-5334

NameCVE-2017-5334
DescriptionDouble free vulnerability in the gnutls_x509_ext_import_proxy function in GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allows remote attackers to have unspecified impact via crafted policy language information in an X.509 certificate with a Proxy Certificate Information extension.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls28 (PTS)jessie3.3.8-6+deb8u7fixed
jessie (security)3.3.8-6+deb8u6fixed
stretch3.5.8-5+deb9u3fixed
stretch (security)3.5.8-5+deb9u1fixed
buster3.5.15-2fixed
sid3.5.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls28source(unstable)3.5.8-1high
gnutls28sourcejessie3.3.8-6+deb8u5high

Notes

https://gnutls.org/security.html#GNUTLS-SA-2017-1
https://gitlab.com/gnutls/gnutls/commit/c5aaa488a3d6df712dc8dff23a049133cab5ec1b

Search for package or bug name: Reporting problems