CVE-2017-5335

NameCVE-2017-5335
DescriptionThe stream reading functions in lib/opencdk/read-packet.c in GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allow remote attackers to cause a denial of service (out-of-memory error and crash) via a crafted OpenPGP certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls26 (PTS)wheezy, wheezy (security)2.12.20-8+deb7u5vulnerable
gnutls28 (PTS)jessie3.3.8-6+deb8u5fixed
jessie (security)3.3.8-6+deb8u6fixed
stretch3.5.8-5fixed
stretch (security)3.5.8-5+deb9u1fixed
buster3.5.8-6fixed
sid3.5.13-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls26source(unstable)(unfixed)medium
gnutls28source(unstable)3.5.8-1medium
gnutls28sourcejessie3.3.8-6+deb8u5medium

Notes

[wheezy] - gnutls26 <no-dsa> (Minor issue)
OpenPGP-related issue
https://gnutls.org/security.html#GNUTLS-SA-2017-2
https://gitlab.com/gnutls/gnutls/commit/49be4f7b82eba2363bb8d4090950dad976a77a3a

Search for package or bug name: Reporting problems