CVE-2017-5336

NameCVE-2017-5336
DescriptionStack-based buffer overflow in the cdk_pk_get_keyid function in lib/opencdk/pubkey.c in GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allows remote attackers to have unspecified impact via a crafted OpenPGP certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls26 (PTS)wheezy (security), wheezy2.12.20-8+deb7u5vulnerable
gnutls28 (PTS)jessie3.3.8-6+deb8u4vulnerable
jessie (security)3.3.8-6+deb8u2vulnerable
stretch, sid3.5.8-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls26source(unstable)(unfixed)high
gnutls28source(unstable)3.5.8-1high

Notes

[jessie] - gnutls28 <no-dsa> (Minor issue, will be fixed via point update)
[wheezy] - gnutls26 <no-dsa> (Minor issue)
OpenPGP-related
https://gnutls.org/security.html#GNUTLS-SA-2017-2
https://gitlab.com/gnutls/gnutls/commit/5140422e0d7319a8e2fe07f02cbcafc4d6538732

Search for package or bug name: Reporting problems