CVE-2017-5357

NameCVE-2017-5357
Descriptionregex.c in GNU ed before 1.14.1 allows attackers to cause a denial of service (crash) via a malformed command, which triggers an invalid free.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ed (PTS)buster1.15-1fixed
bullseye1.17-1fixed
bookworm, sid1.19-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
edsource(unstable)(not affected)

Notes

- ed <not-affected> (Vulnerable code not present, cf #851159)
https://www.openwall.com/lists/oss-security/2017/01/12/5
The issue is only present from 1.14 onwards, and prior to 1.14.1 since upstream
changed a malloc'ed buffer for a static one.
https://lists.gnu.org/archive/html/bug-ed/2017-01/msg00001.html

Search for package or bug name: Reporting problems