CVE-2017-5386

NameCVE-2017-5386
DescriptionWebExtension scripts can use the "data:" protocol to affect pages loaded by other web extensions using this protocol, leading to potential data disclosure or privilege escalation in affected extensions. This vulnerability affects Firefox ESR < 45.7 and Firefox < 51.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-800-1, DSA-3771-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid83.0-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1fixed
stretch (security)78.5.0esr-1~deb9u1fixed
buster68.12.0esr-1~deb10u1fixed
buster (security)78.5.0esr-1~deb10u1fixed
bullseye, sid78.5.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)51.0-1
firefox-esrsourcewheezy45.7.0esr-1~deb7u1DLA-800-1
firefox-esrsourcejessie45.7.0esr-1~deb8u1DSA-3771-1
firefox-esrsource(unstable)45.7.0esr-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2017-01/#CVE-2017-5386
https://www.mozilla.org/en-US/security/advisories/mfsa2017-02/#CVE-2017-5386

Search for package or bug name: Reporting problems