CVE-2017-5407

NameCVE-2017-5407
DescriptionUsing SVG filters that don't use the fixed point math implementation on a target iframe, a malicious page can extract pixel values from a targeted user. This can be used to extract history information and read text values across domains. This violates same-origin policy and leads to information disclosure. This vulnerability affects Firefox < 52, Firefox ESR < 45.8, Thunderbird < 52, and Thunderbird < 45.8.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-852-1, DLA-896-1, DSA-3805-1, DSA-3832-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid62.0.2-1fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1fixed
jessie (security)52.9.0esr-1~deb8u1fixed
stretch52.9.0esr-1~deb9u1fixed
stretch (security)60.2.1esr-1~deb9u1fixed
buster52.9.0esr-1fixed
sid60.2.1esr-1fixed
icedove (PTS)jessie1:52.3.0-4~deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)52.0-1medium
firefox-esrsource(unstable)45.8.0esr-1medium
firefox-esrsourcejessie45.8.0esr-1~deb8u1mediumDSA-3805-1
firefox-esrsourcewheezy45.8.0esr-1~deb7u1mediumDLA-852-1
icedovesource(unstable)1:45.8.0-1medium
icedovesourcejessie1:45.8.0-3~deb8u1mediumDSA-3832-1
icedovesourcewheezy1:45.8.0-3~deb7u1mediumDLA-896-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2017-05/#CVE-2017-5407
https://www.mozilla.org/en-US/security/advisories/mfsa2017-06/#CVE-2017-5407
https://www.mozilla.org/en-US/security/advisories/mfsa2017-07/#CVE-2017-5407

Search for package or bug name: Reporting problems