CVE-2017-5461

NameCVE-2017-5461
DescriptionMozilla Network Security Services (NSS) before 3.21.4, 3.22.x through 3.28.x before 3.28.4, 3.29.x before 3.29.5, and 3.30.x before 3.30.1 allows remote attackers to cause a denial of service (out-of-bounds write) or possibly have unspecified other impact by leveraging incorrect base64 operations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-906-1, DLA-946-1, DSA-3831-1, DSA-3872-1
NVD severityhigh (attack range: remote)
Debian Bugs862958

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid54.0-2fixed
firefox-esr (PTS)wheezy (security)52.2.0esr-1~deb7u1fixed
jessie45.9.0esr-1~deb8u1fixed
jessie (security)52.2.0esr-1~deb8u1fixed
nss (PTS)wheezy2:3.14.5-1+deb7u5vulnerable
wheezy (security)2:3.26-1+debu7u4fixed
jessie2:3.26-1+debu8u1vulnerable
jessie (security)2:3.26-1+debu8u2fixed
stretch2:3.26.2-1.1fixed
buster, sid2:3.31-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)52.0.1-1high
firefox-esrsourcejessie45.9.0esr-1~deb8u1highDSA-3831-1
firefox-esrsourcewheezy45.9.0esr-1~deb7u1highDLA-906-1
nsssource(unstable)2:3.26.2-1.1high862958
nsssourceexperimental2:3.30.1-1high
nsssourcejessie2:3.26-1+debu8u2highDSA-3872-1
nsssourcewheezy2:3.26-1+debu7u3highDLA-946-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2017-10/#CVE-2017-5461
https://bugzilla.mozilla.org/show_bug.cgi?id=1344380
https://hg.mozilla.org/projects/nss/rev/77a5bb81dbaa

Search for package or bug name: Reporting problems