CVE-2017-5490

NameCVE-2017-5490
DescriptionCross-site scripting (XSS) vulnerability in the theme-name fallback functionality in wp-includes/class-wp-theme.php in WordPress before 4.7.1 allows remote attackers to inject arbitrary web script or HTML via a crafted directory name of a theme, related to wp-admin/includes/class-theme-installer-skin.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-813-1, DSA-3779-1
NVD severitymedium
Debian Bugs851310

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch4.7.5+dfsg-2+deb9u6fixed
stretch (security)4.7.21+dfsg-0+deb9u1fixed
buster5.0.12+dfsg1-0+deb10u1fixed
buster (security)5.0.14+dfsg1-0+deb10u1fixed
bullseye5.7.1+dfsg1-2fixed
bullseye (security)5.7.3+dfsg1-0+deb11u1fixed
bookworm, sid5.8.1+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcewheezy3.6.1+dfsg-1~deb7u13DLA-813-1
wordpresssourcejessie4.1+dfsg-1+deb8u12DSA-3779-1
wordpresssource(unstable)4.7.1+dfsg-1851310

Notes

https://www.openwall.com/lists/oss-security/2017/01/14/1
https://wpvulndb.com/vulnerabilities/8718
https://github.com/WordPress/WordPress/commit/ce7fb2934dd111e6353784852de8aea2a938b359

Search for package or bug name: Reporting problems