CVE-2017-5493

NameCVE-2017-5493
Descriptionwp-includes/ms-functions.php in the Multisite WordPress API in WordPress before 4.7.1 does not properly choose random numbers for keys, which makes it easier for remote attackers to bypass intended access restrictions via a crafted (1) site signup or (2) user signup.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-813-1, DSA-3779-1
Debian Bugs851310

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)buster5.0.15+dfsg1-0+deb10u1fixed
buster (security)5.0.18+dfsg1-0+deb10u1fixed
bullseye5.7.5+dfsg1-0+deb11u1fixed
bullseye (security)5.7.8+dfsg1-0+deb11u2fixed
bookworm6.0.3+dfsg1-1fixed
sid6.1+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcewheezy3.6.1+dfsg-1~deb7u13DLA-813-1
wordpresssourcejessie4.1+dfsg-1+deb8u12DSA-3779-1
wordpresssource(unstable)4.7.1+dfsg-1851310

Notes

https://www.openwall.com/lists/oss-security/2017/01/14/1
https://wpvulndb.com/vulnerabilities/8721
https://github.com/WordPress/WordPress/commit/cea9e2dc62abf777e06b12ec4ad9d1aaa49b29f4

Search for package or bug name: Reporting problems