CVE-2017-5507

NameCVE-2017-5507
DescriptionMemory leak in coders/mpc.c in ImageMagick before 6.9.7-4 and 7.x before 7.0.4-4 allows remote attackers to cause a denial of service (memory consumption) via vectors involving a pixel cache.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-807-1, DSA-3799-1
NVD severityhigh (attack range: remote)
Debian Bugs851382

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4vulnerable
wheezy (security)8:6.7.7.10-5+deb7u18fixed
jessie (security), jessie8:6.8.9.9-5+deb8u11fixed
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u3fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.7.4+dfsg-1high851382
imagemagicksourcejessie8:6.8.9.9-5+deb8u7highDSA-3799-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u11highDLA-807-1

Notes

https://github.com/ImageMagick/ImageMagick/commit/4493d9ca1124564da17f9b628ef9d0f1a6be9738
http://www.openwall.com/lists/oss-security/2017/01/16/6

Search for package or bug name: Reporting problems