CVE-2017-5511

NameCVE-2017-5511
Descriptioncoders/psd.c in ImageMagick allows remote attackers to have unspecified impact by leveraging an improper cast, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-807-1, DSA-3799-1
NVD severityhigh (attack range: remote)
Debian Bugs851374

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4vulnerable
wheezy (security)8:6.7.7.10-5+deb7u18fixed
jessie8:6.8.9.9-5+deb8u9fixed
jessie (security)8:6.8.9.9-5+deb8u11fixed
stretch8:6.9.7.4+dfsg-11+deb9u1fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u3fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.7.4+dfsg-1high851374
imagemagicksourcejessie8:6.8.9.9-5+deb8u7highDSA-3799-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u11highDLA-807-1

Notes

https://github.com/ImageMagick/ImageMagick/issues/347
http://www.openwall.com/lists/oss-security/2017/01/16/6
https://github.com/ImageMagick/ImageMagick/commit/7d65a814ac76bd04760072c33e452371692ee790

Search for package or bug name: Reporting problems