CVE-2017-5522

NameCVE-2017-5522
DescriptionStack-based buffer overflow in MapServer before 6.0.6, 6.2.x before 6.2.4, 6.4.x before 6.4.5, and 7.0.x before 7.0.4 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via vectors involving WFS get feature requests.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-790-1, DSA-3766-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mapserver (PTS)wheezy6.0.1-3.2+deb7u2vulnerable
wheezy (security)6.0.1-3.2+deb7u4fixed
jessie (security), jessie6.4.1-5+deb8u3fixed
stretch7.0.4-2fixed
buster, sid7.0.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mapserversource(unstable)7.0.4-1high
mapserversourcejessie6.4.1-5+deb8u3highDSA-3766-1
mapserversourcewheezy6.0.1-3.2+deb7u4highDLA-790-1

Notes

https://lists.osgeo.org/pipermail/mapserver-dev/2017-January/015007.html
https://github.com/mapserver/mapserver/commit/e52a436c0e1c5e9f7ef13428dba83194a800f4df

Search for package or bug name: Reporting problems