CVE-2017-5547

NameCVE-2017-5547
Descriptiondrivers/hid/hid-corsair.c in the Linux kernel 4.9.x before 4.9.6 interacts incorrectly with the CONFIG_VMAP_STACK option, which allows local users to cause a denial of service (system crash or memory corruption) or possibly have unspecified other impact by leveraging use of more than one virtual page for a DMA scatterlist.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1fixed
wheezy (security)3.2.96-3fixed
jessie3.16.51-2fixed
jessie (security)3.16.51-3+deb8u1fixed
stretch (security), stretch4.9.82-1+deb9u3fixed
buster4.15.11-1fixed
sid4.15.17-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.9.6-1high
linuxsourcejessie(not affected)
linuxsourcewheezy(not affected)

Notes

[jessie] - linux <not-affected> (Vulnerable code introduced in v4.4-rc1)
[wheezy] - linux <not-affected> (Vulnerable code introduced in v4.4-rc1)
Fixed by: https://git.kernel.org/linus/6d104af38b570d37aa32a5803b04c354f8ed513d

Search for package or bug name: Reporting problems