CVE-2017-5551

NameCVE-2017-5551
DescriptionThe simple_set_acl function in fs/posix_acl.c in the Linux kernel before 4.9.6 preserves the setgid bit during a setxattr call involving a tmpfs filesystem, which allows local users to gain group privileges by leveraging the existence of a setgid program with restrictions on execute permissions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-7097.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3791-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1vulnerable
wheezy (security)3.2.96-3fixed
jessie3.16.51-2fixed
jessie (security)3.16.51-3+deb8u1fixed
stretch4.9.65-3fixed
stretch (security)4.9.65-3+deb9u2fixed
buster4.14.13-1fixed
sid4.15.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.9.6-1low
linuxsourcejessie3.16.39-1+deb8u1lowDSA-3791-1
linuxsourcewheezy3.2.84-1low

Notes

Backported fix for CVE-2016-7097 already covered this CVE for wheezy
Fixed by: https://git.kernel.org/linus/497de07d89c1410d76a15bec2bb41f24a2a89f31 (4.10-rc4)

Search for package or bug name: Reporting problems