CVE-2017-5610

NameCVE-2017-5610
Descriptionwp-admin/includes/class-wp-press-this.php in Press This in WordPress before 4.7.2 does not properly restrict visibility of a taxonomy-assignment user interface, which allows remote attackers to bypass intended access restrictions by reading terms.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-813-1, DSA-3779-1
NVD severitymedium
Debian Bugs852767

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch4.7.5+dfsg-2+deb9u6fixed
stretch (security)4.7.21+dfsg-0+deb9u1fixed
buster5.0.12+dfsg1-0+deb10u1fixed
buster (security)5.0.14+dfsg1-0+deb10u1fixed
bullseye5.7.1+dfsg1-2fixed
bullseye (security)5.7.3+dfsg1-0+deb11u1fixed
bookworm, sid5.8.1+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcewheezy3.6.1+dfsg-1~deb7u13DLA-813-1
wordpresssourcejessie4.1+dfsg-1+deb8u12DSA-3779-1
wordpresssource(unstable)4.7.2+dfsg-1852767

Notes

https://github.com/WordPress/WordPress/commit/21264a31e0849e6ff793a06a17de877dd88ea454
https://www.openwall.com/lists/oss-security/2017/01/27/2

Search for package or bug name: Reporting problems