CVE-2017-5612

NameCVE-2017-5612
DescriptionCross-site scripting (XSS) vulnerability in wp-admin/includes/class-wp-posts-list-table.php in the posts list table in WordPress before 4.7.2 allows remote attackers to inject arbitrary web script or HTML via a crafted excerpt.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-813-1, DSA-3779-1
NVD severitymedium (attack range: remote)
Debian Bugs852767

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10vulnerable
wheezy (security)3.6.1+dfsg-1~deb7u16fixed
jessie4.1+dfsg-1+deb8u14fixed
jessie (security)4.1+dfsg-1+deb8u15fixed
stretch4.7.5+dfsg-2fixed
stretch (security)4.7.5+dfsg-2+deb9u1fixed
buster, sid4.8.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.7.2+dfsg-1medium852767
wordpresssourcejessie4.1+dfsg-1+deb8u12mediumDSA-3779-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u13mediumDLA-813-1

Notes

https://github.com/WordPress/WordPress/commit/4482f9207027de8f36630737ae085110896ea849
http://www.openwall.com/lists/oss-security/2017/01/27/2

Search for package or bug name: Reporting problems