CVE-2017-5617

NameCVE-2017-5617
DescriptionThe SVG Salamander (aka svgSalamander) library, when used in a web application, allows remote attackers to conduct server-side request forgery (SSRF) attacks via an xlink:href attribute in an SVG file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-816-1, DSA-3781-1
NVD severitymedium (attack range: remote)
Debian Bugs853134

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
svgsalamander (PTS)wheezy0~svn95-1vulnerable
wheezy (security)0~svn95-1+deb7u1fixed
jessie (security), jessie0~svn95-1+deb8u1fixed
buster, sid, stretch1.1.1+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
svgsalamandersource(unstable)1.1.1+dfsg-2medium853134
svgsalamandersourcejessie0~svn95-1+deb8u1mediumDSA-3781-1
svgsalamandersourcewheezy0~svn95-1+deb7u1mediumDLA-816-1

Notes

https://github.com/blackears/svgSalamander/issues/11
http://www.openwall.com/lists/oss-security/2017/01/27/3

Search for package or bug name: Reporting problems