CVE-2017-5637

NameCVE-2017-5637
DescriptionTwo four letter word commands "wchp/wchc" are CPU intensive and could cause spike of CPU utilization on Apache ZooKeeper server if abused, which leads to the server unable to serve legitimate client requests. Apache ZooKeeper thru version 3.4.9 and 3.5.2 suffer from this issue, fixed in 3.4.10, 3.5.3, and later.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-986-1, DSA-3871-1
NVD severitymedium (attack range: remote)
Debian Bugs863811

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zookeeper (PTS)wheezy3.3.5+dfsg1-2vulnerable
wheezy (security)3.4.5+dfsg-2+deb7u1fixed
jessie (security), jessie3.4.5+dfsg-2+deb8u2fixed
stretch3.4.9-3fixed
buster, sid3.4.10-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zookeepersource(unstable)3.4.9-3medium863811
zookeepersourcejessie3.4.5+dfsg-2+deb8u2mediumDSA-3871-1
zookeepersourcewheezy3.4.5+dfsg-2+deb7u1mediumDLA-986-1

Notes

https://issues.apache.org/jira/browse/ZOOKEEPER-2693

Search for package or bug name: Reporting problems