CVE-2017-5647

NameCVE-2017-5647
DescriptionA bug in the handling of the pipelined requests in Apache Tomcat 9.0.0.M1 to 9.0.0.M18, 8.5.0 to 8.5.12, 8.0.0.RC1 to 8.0.42, 7.0.0 to 7.0.76, and 6.0.0 to 6.0.52, when send file was used, results in the pipelined request being lost when send file processing of the previous request completed. This could result in responses appearing to be sent for the wrong request. For example, a user agent that sent requests A, B and C could see the correct response for request A, the response for request C for request B and no response for request C.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-924-1, DSA-3842-1, DSA-3843-1
NVD severitymedium (attack range: remote)
Debian Bugs802312, 860068

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat6 (PTS)wheezy6.0.45+dfsg-1~deb7u1fixed
wheezy (security)6.0.45+dfsg-1~deb7u5fixed
jessie (security), jessie6.0.45+dfsg-1~deb8u1fixed
tomcat7 (PTS)wheezy7.0.28-4+deb7u4vulnerable
wheezy (security)7.0.28-4+deb7u14fixed
jessie (security), jessie7.0.56-3+deb8u11fixed
stretch7.0.75-1fixed
buster, sid7.0.78-1fixed
tomcat8 (PTS)jessie (security), jessie8.0.14-1+deb8u10fixed
stretch (security), stretch8.5.14-1+deb9u1fixed
buster, sid8.5.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat6source(unstable)6.0.41-3medium
tomcat7source(unstable)7.0.72-3medium
tomcat7sourcejessie7.0.56-3+deb8u10mediumDSA-3842-1
tomcat7sourcewheezy7.0.28-4+deb7u12mediumDLA-924-1
tomcat8source(unstable)8.5.11-2medium860068
tomcat8sourcejessie8.0.14-1+deb8u9mediumDSA-3843-1
tomcat9ITP802312

Notes

Since 7.0.72-3, src:tomcat7 only builds the Servlet API
Since 6.0.41-3, src:tomcat6 only builds a servlet and docs in Jessie
http://www.openwall.com/lists/oss-security/2017/04/10/24
Fixed by: http://svn.apache.org/r1788932 (8.5.x)
Fixed by: http://svn.apache.org/r1788999 (8.0.x)
Fixed by: http://svn.apache.org/r1789008 (7.0.x)
Fixed by: http://svn.apache.org/r1789024 (6.0.x)
Fixed by: http://svn.apache.org/r1789155 (6.0.x)
Fixed by: http://svn.apache.org/r1789856 (6.0.x)

Search for package or bug name: Reporting problems