CVE-2017-5660

NameCVE-2017-5660
DescriptionThere is a vulnerability in Apache Traffic Server (ATS) 6.2.0 and prior and 7.0.0 and prior with the Host header and line folding. This can have issues when interacting with upstream proxies and the wrong host being used.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4128-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
trafficserver (PTS)stretch (security), stretch7.0.0-6+deb9u1fixed
sid7.1.3+ds-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
trafficserversource(unstable)7.1.2+ds-1medium
trafficserversourcestretch7.0.0-6+deb9u1mediumDSA-4128-1
trafficserversourcewheezy(not affected)

Notes

[wheezy] - trafficserver <not-affected> (Vulnerable code not present)
https://github.com/apache/trafficserver/pull/1657
https://issues.apache.org/jira/browse/TS-4930

Search for package or bug name: Reporting problems