CVE-2017-5668

NameCVE-2017-5668
Descriptionbitlbee-libpurple before 3.5.1 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list. NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-10189.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs853282

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bitlbee (PTS)jessie (security), jessie3.2.2-2+deb8u1fixed
stretch3.5.1-1fixed
buster3.5.1-1.3fixed
sid3.6-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bitlbeesource(unstable)3.5.1-1high853282
bitlbeesourcejessie(not affected)
bitlbeesourcewheezy(not affected)

Notes

[jessie] - bitlbee <not-affected> (Incomplete fix for CVE-2016-10189 not applied)
[wheezy] - bitlbee <not-affected> (Incomplete fix for CVE-2016-10189 not applied)
https://bugs.bitlbee.org/ticket/1282
Fixed by: https://github.com/bitlbee/bitlbee/commit/30d598ce7cd3f136ee9d7097f39fa9818a272441 (3.5.1)
http://www.openwall.com/lists/oss-security/2017/01/30/4
This CVE exists because of an incomplete fix for CVE-2016-10189

Search for package or bug name: Reporting problems