CVE-2017-5846

NameCVE-2017-5846
DescriptionThe gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-829-1, DSA-3821-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-ugly0.10 (PTS)wheezy0.10.19-2vulnerable
wheezy (security)0.10.19-2+deb7u1fixed
jessie0.10.19-2.1vulnerable
gst-plugins-ugly1.0 (PTS)jessie (security), jessie1.4.4-2+deb8u1fixed
stretch, sid1.10.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-ugly0.10source(unstable)(unfixed)low
gst-plugins-ugly0.10sourcewheezy0.10.19-2+deb7u1mediumDLA-829-1
gst-plugins-ugly1.0source(unstable)1.10.3-1low
gst-plugins-ugly1.0sourcejessie1.4.4-2+deb8u1mediumDSA-3821-1

Notes

[jessie] - gst-plugins-ugly0.10 <no-dsa> (Minor issue)
http://www.openwall.com/lists/oss-security/2017/02/01/7
https://bugzilla.gnome.org/show_bug.cgi?id=777937

Search for package or bug name: Reporting problems