CVE-2017-5847

NameCVE-2017-5847
DescriptionThe gst_asf_demux_process_ext_content_desc function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer allows remote attackers to cause a denial of service (out-of-bounds heap read) via vectors involving extended content descriptors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2226-1, DLA-829-1, DSA-3821-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-ugly1.0 (PTS)stretch1.10.4-1fixed
buster1.14.4-1fixed
bullseye, sid1.16.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-ugly0.10sourcewheezy0.10.19-2+deb7u1DLA-829-1
gst-plugins-ugly0.10sourcejessie0.10.19-2.1+deb8u1DLA-2226-1
gst-plugins-ugly0.10source(unstable)(unfixed)low
gst-plugins-ugly1.0sourcejessie1.4.4-2+deb8u1DSA-3821-1
gst-plugins-ugly1.0source(unstable)1.10.4-1low

Notes

http://www.openwall.com/lists/oss-security/2017/02/01/7
https://bugzilla.gnome.org/show_bug.cgi?id=777955
https://github.com/GStreamer/gst-plugins-ugly/commit/d21017b52a585f145e8d62781bcc1c5fefc7ee37

Search for package or bug name: Reporting problems