CVE-2017-5853

NameCVE-2017-5853
DescriptionInteger overflow in base/PdfParser.cpp in PoDoFo 0.9.4 allows remote attackers to have unspecified impact via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-929-1
NVD severitymedium (attack range: remote)
Debian Bugs854601

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpodofo (PTS)wheezy0.9.0-1.1vulnerable
wheezy (security)0.9.0-1.1+deb7u2fixed
jessie0.9.0-1.2vulnerable
stretch0.9.4-6fixed
buster, sid0.9.5-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpodofosource(unstable)0.9.4-5medium854601
libpodofosourcewheezy0.9.0-1.1+deb7u1mediumDLA-929-1

Notes

[jessie] - libpodofo <no-dsa> (Minor issue)
https://blogs.gentoo.org/ago/2017/02/01/podofo-signed-integer-overflow-in-pdfparser-cpp
https://sourceforge.net/p/podofo/mailman/podofo-users/thread/12497325.VLNgGImML2%40blackgate/#msg35640936
Proposed fix: https://sourceforge.net/p/podofo/mailman/message/35692197/
upstream commit: https://sourceforge.net/p/podofo/code/1840/

Search for package or bug name: Reporting problems