CVE-2017-5886

NameCVE-2017-5886
DescriptionHeap-based buffer overflow in the PoDoFo::PdfTokenizer::GetNextToken function in PdfTokenizer.cpp in PoDoFo 0.9.4 allows remote attackers to have unspecified impact via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-929-1
NVD severitymedium (attack range: remote)
Debian Bugs854604

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpodofo (PTS)wheezy0.9.0-1.1vulnerable
wheezy (security)0.9.0-1.1+deb7u2fixed
jessie0.9.0-1.2vulnerable
stretch0.9.4-6fixed
buster, sid0.9.5-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpodofosource(unstable)0.9.4-5medium854604
libpodofosourcewheezy0.9.0-1.1+deb7u1mediumDLA-929-1

Notes

[jessie] - libpodofo <no-dsa> (Minor issue)
https://blogs.gentoo.org/ago/2017/02/03/podofo-heap-based-buffer-overflow-in-podofopdftokenizergetnexttoken-pdftokenizer-cpp
https://sourceforge.net/p/podofo/mailman/podofo-users/thread/1623824.EtgW9yDooZ%40blackgate/#msg35644693
upstream commit: https://sourceforge.net/p/podofo/code/1837

Search for package or bug name: Reporting problems